Project

General

Profile

SSD on MityDSP-L138F

Added by Hannes Klas about 6 years ago

Hey folks,

I'm trying to use a SSD instead of a HDD on the L138F.

I found in the errata that the OMAP-L138 has a problem with SATA devices capable of SATA 3. I'm using a Samsung 840 evo.

The kernel detected the disk once, but didn't afterwards. The disk works fine on an USB-Adapter.

The errata mentions as a workaround to reset the SATA-Device. Do you have an idea how to do that on the linux kernel? It would be preferable to do this during boot, as i want to supply my RootFS from the SSD.

Regards
Hannes


Replies (1)

RE: SSD on MityDSP-L138F - Added by Bob Duke about 6 years ago

Hannes,

As mentioned in the errata, they do not recommend the "reset" approach because they cannot guarantee that it will work in a reasonable amount of time.

If you are going to go down this path, I suggest you test this approach from a running system: Plug in the SSD drive, but put your root filesystem from somewhere else (NFS, SD, etc.). If the SSD drive is not detected, try to run a rescan by using:

# echo "- - -" > /sys/devices/platform/ahci/host0/scsi_host/host0/scan

You may have to run dmesg after this command to see if the drive was detected. If you can get this to work, then maybe you can modify the kernel to keep rescanning until it is successful.

You can also try forcing the kernel to use a specific link speed for a specific drive (look at libata.force= in https://www.kernel.org/doc/Documentation/kernel-parameters.txt).

As mentioned in the errata, using a SATA1 or SATA2 drive may be the best option, if possible.

-Bob

    (1-1/1)
    Add picture from clipboard (Maximum size: 500 MB)