Project

General

Profile

Failed to reprogram dead board

Added by Andri Haryono over 3 years ago

Hello,

I am trying to update the MDK on my MityDSP L138 using MDK_2014-01-13. However somehow it's failed.
I follow how to reprogram dead board using mono in my ubuntu 16.04

but this is what i got

root@PI-computer:~/Documents/sfh_ubl_072111# mono sfh_OMAP-L138.exe -flash -v -p /dev/ttyUSB0 UBL_SPI_MEM.ais u-boot.bin
WARNING: The runtime version supported by this application is unavailable.
Using default runtime: v4.0.30319
-----------------------------------------------------
   TI Serial Flasher Host Program for OMAP-L138
   (C) 2010, Texas Instruments, Inc.
   Ver. 1.67
-----------------------------------------------------

      [TYPE] UBL and application image
       [UBL] UBL_SPI_MEM.ais
 [APP IMAGE] u-boot.bin
    [TARGET] OMAPL138
    [DEVICE] SPI_MEM

Attempting to connect to device /dev/ttyUSB0...
Press any key to end this program at any time.

(AIS Parse): Read magic word 0x41504954.
(AIS Parse): Waiting for BOOTME... (power on or reset target now)
(Serial Port): Read error! (The operation has timed out.)
(AIS Parse): Read invalid BOOTME string.
(AIS Parse): Boot aborted.
Booting SFT failed. Trying again (you may need to reset the target)...
(AIS Parse): Read magic word 0x41504954.
(AIS Parse): Waiting for BOOTME... (power on or reset target now)
(AIS Parse): Read invalid BOOTME string.
(AIS Parse): Boot aborted.
Booting SFT failed. Trying again (you may need to reset the target)...
(AIS Parse): Read magic word 0x41504954.
(AIS Parse): Waiting for BOOTME... (power on or reset target now)
(AIS Parse): Read invalid BOOTME string.
(AIS Parse): Boot aborted.
Booting SFT failed. Trying again (you may need to reset the target)...

How to solve this issue?

thanks


Replies (3)

RE: Failed to reprogram dead board - Added by Andri Haryono over 3 years ago

sorry it was MityDSP-L138-FI-236-RL

RE: Failed to reprogram dead board - Added by Tim Iskander over 3 years ago

I have to ask...
Are you holding the boot button down while powering on the board (assuming you are using the Critical Link Development kit board).
I have never actually tried running the sfh_OMAP-L138.exe app using mono, so I don't know if the

WARNING: The runtime version supported by this application is unavailable.
Using default runtime: v4.0.30319

message is significant or not.
The messages shown clearly are saying that the flash app is not seeing the magic "BOOTME" string from the device.
It could also be that your serial port is not set to the correct 115200-N-8-1 settings. (sudo stty -aF /dev/ttyUSB0)

RE: Failed to reprogram dead board - Added by Andri Haryono about 3 years ago

Thank you.

I miss the "Holding boot button" part. now it's okay

    (1-3/3)
    Add picture from clipboard (Maximum size: 500 MB)