Project

General

Profile

Running SYS/BIOS on the ARM MityDSP-L138 module

Added by Anonymous almost 9 years ago

Hi,

I'm currently using a Spectrum Digital's OMAP-L137 eval board to run some older DSP code and I'd like to have the ARM collect Ethernet 
data via TI's NDK and pass it through to the DSP. Because there seems to be no underlying drivers for TI's NDK on a OMAPL137 were looking
for alternatives. We have a MityDSP-L138 development board and was wondering if anyone had run SYS/BIOS on the ARM side of the 138 as
there seems to be support for TI's NDK on the 138. Mity normally runs Linux on the ARM, but we've been using Code Composer V5.1 with
JTAG to debug and was hoping to keep the same development environment.
From the descriptions on the website the Mity supports SYS/BIOS and JTAG, but is this only on the DSP side?

Any help/suggestions would be appreciated.

Thanks,

John C.

Replies (2)

RE: Running SYS/BIOS on the ARM MityDSP-L138 module - Added by Dave Stehlik almost 9 years ago

This is something that we haven't done yet.

TI has some info on this: here are some links that may be worth exploring:

TI's starterware:
http://processors.wiki.ti.com/index.php/StarterWare

and SYSBIOS wiki:
http://processors.wiki.ti.com/index.php/Category:SYSBIOS

There may be some useful information from searching TI's e2e site:
http://e2e.ti.com/

If someone else has additional info please feel free to post it.

Dave

RE: Running SYS/BIOS on the ARM MityDSP-L138 module - Added by Anonymous almost 9 years ago

Dave,
I've been over on the e2e forum for a couple weeks getting our current DSP
running on the OMAP137. TI has confirmed that their Network Development Package
does not support the 137. So I'll need to get a 138 dev board and had hoped
yours would have been a quick solution.

Thanks,
John C.
CiDRA

    (1-2/2)
    Add picture from clipboard (Maximum size: 2 GB)