Project

General

Profile

Linux DaVinci Video Port Interface (VPIF)

Added by Terrence Lawrence about 8 years ago

I need to setup a VPIF interface (ala V4L2) using a Mity OMAP-L138F SoM platform running DaVinci Linux to support, BT.656, 8-bit, 720x480, composite (CBVS) video output only.

I have attempted to make customizations to the Linux kernel code in the board configuration module, board-mityomal138.c. Which derives from board-da850.c. I added software changes to perform the pin mux setup of the VPIF display pins, register the VPIF chip, the VPIF display device interface, and the video encoder chip.

Thus far, using TI’s ‘vpif_test_display’ application, and the V4L2 video stack. I have been able to successfully display color bars directly from the ADV7391 video encoder, to a analog display that’s connected to the SoM’s custom baseboard.

However, if I try to display a frame from memory using a known Y/C pattern. I get a blank screen. Connecting a scope to a few of the VPIF’s pins, such as CLKOUT2, DOUT7, and DOUT3. We were able to verify that the VPIF’s CLKOUT2 pin is putting out a 27 MHz clock. But pins DOUT3 and DOUT7 are flat lined at about 0V.


Replies (1)

RE: Linux DaVinci Video Port Interface (VPIF) - Added by Michael Williamson about 8 years ago

Hello,

This post should probably go over in the standard ARM-9 Modules Software Forum

This project is really intended to support folks using the QNX port for the MityDSP-L138 or MityARM-1808 platforms.

As for your question:

We haven't used the linux V4L2 stack here with the OMAP-L138 processor SOMS yet, so I'm not sure how much help we can provide. It sounds like perhaps the VPIF output is not getting frame update events from your test code or the output DMA FIFO may be stalling. You might try to post to the TI E2E site as this is more of a processor specific question as opposed to a module issue.

-Mike

    (1-1/1)
    Add picture from clipboard (Maximum size: 2 GB)