Project

General

Profile

Need Help for Audio MityDSP-L138F. DSP Platforms. No Linux Based

Added by riyanto fisika almost 4 years ago

Hello, I'm new using MityDSP, actually I'm moving from evmOMAPL138 to MityDSP.

I generate sine signal then want to play it through DSD1791 DAC so I can hear it. I already set the MCASP but there is no output sound.
I build the program on dsp platform and not linux based using CCS v6.1 also using JTAG to debug the program (Windows Operating System)

Can anyone help me with this problem? Dees I miss something? I can't move on to next step because this problem still not solve yet. Are there any example to setup audio on dsp based and also not linux based? Because I just found example on ARM and also Linux based


Replies (2)

RE: Need Help for Audio MityDSP-L138F. DSP Platforms. No Linux Based - Added by Bob Duke almost 4 years ago

Hi Riyanto,

We don't have a ready-to-go example of setting up the DAC outside of Linux. It's difficult to troubleshoot your problem with the limited details provided.

If you are able to post your initialization/setup code here or any information from your debugging efforts, we could take a look at it to see if we can help. Any related schematics you could provide may also help.

-Bob

RE: Need Help for Audio MityDSP-L138F. DSP Platforms. No Linux Based - Added by riyanto fisika almost 4 years ago

Hi Bob,

thank you for your respond, hereby I attached my MCASP setup code, I modify the code from evmomapl138. And for schematic I used the schematic that provided by the critical link. I still got nothing from audio output, may be you can help me with this problem, thank you..

-Riyanto

    (1-2/2)
    Add picture from clipboard (Maximum size: 500 MB)