Project

General

Profile

MityDSP boot problem

Added by caner akcin over 3 years ago

Hi,
We're working on a DSP software on MityDSP_OMAP-L138 board without BIOS and we do not intend to use ARM side in near future. We use COFF libraries whose ELF versions do not exist, thus we are unable to flash the DSP directly appyling bootdsp command in u-boot. There is a bootdsp patch adding ELF boot functionality in https://patchwork.ozlabs.org/patch/314465/ yet the patch is not included in u-boot-ubl.bin binary which MityDSP provides. Are you planning to add this patch? If not, how can I patch it by myself to obtain u-boot-ubl.bin?

Additionally, I also followed TI's procedure using TI's tools in http://processors.wiki.ti.com/index.php/Rebuilding_the_Flash_and_Boot_Utils_Package. I generated .bin AIS file using my own .out file and a customized .ini file. Before flashing, I tried to load application serially to boot the DSP using slh_OMAP-L138.exe binary. Although the loader says that booting completed successfully, the application did not start. (To check, we actually implemented an EMAC server in DSP and checked for ping replies, which was previously tested in TI CCS using XDC100v2 emulator) Is there a specific point we have to consider when using this method?

Thanks.


Replies (5)

RE: MityDSP boot problem - Added by Bob Duke over 3 years ago

Hi Caner,

Regarding U-Boot, the source code for the MityDSP-L138 U-Boot we use can be found on our support site in this git repository: http://support.criticallink.com/gitweb/?p=u-boot-mitydspl138.git;a=summary

Our wiki also has instructions for building U-Boot.

You can try applying that patch to our master branch. Feel free to post to our forums if you have problems with the patch.

RE: MityDSP boot problem - Added by Jonathan Cormier over 3 years ago

It was my understanding that he was trying to build the UBL. In which case the source code is located at MDK_2014-01-13/sw/3rdparty/OMAP-L138_FlashAndBootUtils_2_27

RE: MityDSP boot problem - Added by caner akcin over 3 years ago

Hi,
I followed the instructions in https://support.criticallink.com/redmine/projects/arm9-platforms/wiki/Das_U-Boot_Port:
I fetched files from the git repo

git clone git://support.criticallink.com/home/git/u-boot-mitydspl138.git u-boot-mitydspl138
cd u-boot-mitydspl138

I installed ARM cross tools and required $PATH variables. Then I tried to apply the patch using:
git apply U-Boot-arm-da850-RFC-add-bootdsp-to-cmd_elf.patch

The patch failed, I manually parsed the .patch file and edited the respective files da850.c and cmd_elf.c anyway. I ran the following commands
make ARCH=arm CROSS_COMPILE=arm-angstrom-linux-gnueabi- mityomapl138_config
make ARCH=arm CROSS_COMPILE=arm-angstrom-linux-gnueabi- 

and I obtained u-boot-ubl.bin sucessfully. However the patch did not provide bootdsp command for ELF binaries. After inspection, it turns to be that seems like the patch is restricted to DA850 devices by means of several preprocessor directives. But I can't understand this because the patch here https://patchwork.ozlabs.org/patch/314465/ claims to be tested in OMAP-L138 EVM.

My sole purpose is to awake the DSP side whenever the board is powered. Any other suggestion is greatly appreciated.
Thanks.

RE: MityDSP boot problem - Added by Gregory Gluszek over 3 years ago

Hi Caner,

Have you looked at our wiki page (DSP Programming Quick Start) for launching the DSP without utilizing the ARM? If I am understanding your end goal this may be helpful to you.

Thanks,
\Greg

RE: MityDSP boot problem - Added by caner akcin over 3 years ago

Hi Greg,
Actually this was the page I referenced while I was working on u-boot. In the page, two solutions are suggested. The first one is the bootdsp command which only works for COFF binaries. Being Achilles' heel of the solution, it is also the reason why I've been working on the patch. The second solution is a DSPLINK application on ARM for waking up the DSP. But this one is quite far from underutilization of the ARM side, in fact.
Thanks.

    (1-5/5)
    Add picture from clipboard (Maximum size: 500 MB)