Project

General

Profile

PRU svn authentication failed

Added by Andrew Bean about 4 years ago

When running the following:

svn co https://gforge.ti.com/svn/pru_sw/trunk pru_sw

I get the message

"... Could not authenticate to server: rejected Basic challenge (https://gforge.ti.com)"

Previously, the following worked, but does not work now for some reason (perhaps something changed after doing apt-get update and upgrade?):

svn checkout --username anonymous https://gforge.ti.com/svn/pru_sw/trunk pru_sw

I'm using MityDSP-L138_SDK_2012_06_13.ova. Any help would be greatly appreciated.


Replies (5)

RE: PRU svn authentication failed - Added by Jonathan Cormier about 4 years ago

Found this TI wiki. It appears that you must use the username anonymous with a blank password.
http://processors.wiki.ti.com/index.php/PRU_Linux_Application_Loader#Installing_the_Kernel_Driver

RE: PRU svn authentication failed - Added by Bob Duke about 4 years ago

Andrew, I had no problems with this command:

svn checkout --username anonymous https://gforge.ti.com/svn/pru_sw

Can you please try again and if you have problems, please cut and paste your terminal output?

RE: PRU svn authentication failed - Added by Jonathan Cormier about 4 years ago

Bob Duke wrote:

Andrew, I had no problems with this command:
[...]

Can you please try again and if you have problems, please cut and paste your terminal output?

I've updated the wiki page Using_PRU, to reflect the need to use the username anonymous.

RE: PRU svn authentication failed - Added by Andrew Bean about 4 years ago

I pinged google just to make sure the internet connection is up. Here's what I get:


mitydsp@mitydsp-dev:~$ cd SVN
mitydsp@mitydsp-dev:~/SVN$ ping www.google.com
PING www.google.com (216.58.192.196) 56(84) bytes of data.
64 bytes from ord30s25-in-f196.1e100.net (216.58.192.196): icmp_seq=1 ttl=50 time=4.63 ms
64 bytes from ord30s25-in-f196.1e100.net (216.58.192.196): icmp_seq=2 ttl=50 time=4.93 ms
64 bytes from ord30s25-in-f196.1e100.net (216.58.192.196): icmp_seq=3 ttl=50 time=4.82 ms
64 bytes from ord30s25-in-f196.1e100.net (216.58.192.196): icmp_seq=4 ttl=50 time=4.71 ms
^C
--- www.google.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3007ms
rtt min/avg/max/mdev = 4.639/4.778/4.930/0.120 ms
mitydsp@mitydsp-dev:~/SVN$ svn checkout --username anonymous https://gforge.ti.com/svn/pru_sw
Password for '(null)' GNOME keyring:
svn: OPTIONS of 'https://gforge.ti.com/svn/pru_sw': authorization failed: Could not authenticate to server: rejected Basic challenge (https://gforge.ti.com)
mitydsp@mitydsp-dev:~/SVN$

RE: PRU svn authentication failed - Added by Andrew Bean about 4 years ago

"Password for '(null)' GNOME keyring:" seemed suspect, so i searched on that.

I had to do the following, and then it worked:
rm ~/.gnome2/keyrings/*

    (1-5/5)
    Add picture from clipboard (Maximum size: 500 MB)