Project

General

Profile

Problems with the first time configuration

Added by Hector Bojorquez about 4 years ago

Hi everyone!

I have just acquired the PROFIBUS development kit from Critical Link, I was trying to put it on following the Starter guide steps in Critical Link support page,
I updated and installed the GCC, the MDK and the CDT, I configured the Tool command prefix and the Tool command path when I created the C++ project I needed to edit manually the variable Path for the indicated in the guide,
but I get 2 warnings about:

“Error launching external scanner info generator (g++ -E –P –v –dD /home/mitydsp/workspace/.metadata/.plugins/org.eclipse/cdt.make.core/specs.cpp”,

I ignored them and continued with the process, I typed the code from HelloWorld example and I made the Build it looked there were no problems but when I tried to debug and checked the Error Log there was an Error

Error logged from Debug Core:

In the Console appeared two messages:

/bin/bash: /home/mitydsp/workspace/HelloWorld/Debug/HelloWorld: cannot execute binary file and immediately down
/bin/bash: /home/mitydsp/workspace/HelloWorld/Debug/HelloWorld: Success

I ignored that too and continued with the process in the Starter Guide, I connected the Ethernet cable and I assumed that the target was booted up to Linux /// 1.- How can I verify this?

Then when I used the SCP command I used the IP address assigned to the VM I checked this with ipconfig in the Windows host machine from "Ethernet adapter VirtualBox Host-Only Network" //// 2.- Is this the correct IP I should use?
It looked like the copy went well.

I couldn't install the opkg update, told me that the command didn't found ////// 3.- Is this a critical issue?

I made the ssh root...@ and I got a Linux mitydsp/dev 2.6.32-30... Welcome to Ubuntu! message I went to the /tmp dir and tried to run up the .cpp file but then I got a lot of fail messages most of them about Screen for GtkWindow not set and one syntax error that was not shown in Eclipse.

Am I doing a lot of things wrong? Please let me know which ones.

I'm trying to explain me my best and how you can see I'm a real beginner with this systems, I hope that you can be patient with me and help me out for getting started.

Thanks/ Hector


Replies (35)

RE: Problems with the first time configuration - Added by Hector Bojorquez about 4 years ago

Hi Jonathan,

I made the changes, and yes the problem continues the same, I checked the bootargs and this was the result:

U-Boot > print bootargs
bootargs=mem=96M console=ttyS1, 115200n8 root-/dev/mtdblock0 rw rootwait

If this error doesn't go away with the new u-boot you flashed, I can provide you instructions on setting the config again.

I would appreciate it very much.

bootargs.txt View - Bootargs (1.03 KB)

NANDwrite.txt View - NAND write correction (416 Bytes)

RE: Problems with the first time configuration - Added by Jonathan Cormier about 4 years ago

Hector Bojorquez wrote:

Hi Jonathan,

I made the changes, and yes the problem continues the same, I checked the bootargs and this was the result:

U-Boot > print bootargs
bootargs=mem=96M console=ttyS1, 115200n8 root-/dev/mtdblock0 rw rootwait

There shouldn't be a space in the console arg. "console=ttyS1,115200n8"
Also root should have an '=' not a '-'.

From attachment:UpdatingDevKitMDK.txt

U-Boot > setenv bootcmd "runflashargs; sf probe 0; sf read 0xc0700000 0x100000 0x300000;bootm 0xc0700000"
U-Boot > saveenv

There should be a space between run and flashargs. The run command executes whatever is written into an env variable as if it was typed and run manually. So "run flashargs" will execute the following commands, essentially setting the bootargs variable to the correct settings. Note: The variable bootcmd is autorun during boot or when you execute the command "boot".

U-Boot > print flashargs
flashargs=setenv bootargs ${bootargsbase} ${mtdparts} root=/dev/mtdblock0 rw,noatime rootfstype=jffs2

If this error doesn't go away with the new u-boot you flashed, I can provide you instructions on setting the config again.

I would appreciate it very much.

Actually this is part of the Reprogramming_a_Dead_Board guide. Search for "config set" on that wiki page.

U-Boot 2009.11 (Mar 31 2011 - 19:39:18)

Your u-boot version in attachment:bootargs.txt still shows the old version. The build date for the 2014 MDK is "Jan 13 2014". Please try to update uboot again.

I2C: ready
DRAM: 128 MB
NAND: 256 MiB
MMC: davinci: 0
  • Warning - bad CRC, using default environment

Your previous log attachment:UpdatingDevKitMDK.txt shows you programming the env using "saveenv". This error shouldn't be displaying after you've used "saveenv".

My boot looks like the following:

OMAP-L138/AM-1808/AM-1810 initialization passed!
Configuring 128MB mDDR
                      Booting TI User Boot Loader
        UBL Version: 1.65:2.28.1 BuiltJul 11 2011 12:49:53
        UBL Flashtype: SPI 
Starting SPI Memory Copy...
Valid magicnum, 0x55424CBB, found at offset 0x00010000.
   DONE
Jumping to entry point at 0xC1080000.

U-Boot 2009.11 (Jan 13 2014 - 11:14:02)

I2C:   ready
DRAM:  128 MB
NAND:  256 MiB
MMC:   davinci: 0
In:    serial
Out:   serial
Err:   serial
ARM    Clock : 300000000 Hz
DDR    Clock : 150000000 Hz
EMIFA  CLock : 100000000 Hz
DSP    Clock : 300000000 Hz
ASYNC3 Clock : 150000000 Hz
Enet  config : 2
MMC 0 Enable : 1
Resetting ethernet phy
Net:   Ethernet PHY: GENERIC @ 0x03 [0x8]

Hit any key to stop autoboot:  0 
U-Boot > 

RE: Problems with the first time configuration - Added by Hector Bojorquez about 4 years ago

There shouldn't be a space in the console arg. "console=ttyS1,115200n8"
Also root should have an '=' not a '-'.

sorry about that, I was watching from the other PC and typing in the one with Network connection for making the post, but in the bootlog is OK,

There should be a space between run and flashargs. The run command executes whatever is written into an env variable as if it was typed and run manually. So "run flashargs" will execute the following commands, essentially setting the bootargs variable >to the correct settings. Note: The variable bootcmd is autorun during boot or when you execute the command "boot".

This one was a real error, now corrected.

Actually this is part of the Reprogramming_a_Dead_Board guide. Search for "config set" on that wiki page.

I finished all the steps and made the Flashing again, I got the same bootlog as yours, is attached.

I am able to continue the booting process with the boot command, all the process runs and finish but with a blue letter advice on it about,

Failed to mount /sys/kernel/security: No such file or directory this is attached too.

Blue letter advice

I tried to look for the IP address using root command and later ifconfig there appears some info but without an IP address, you can check it on BootlogError.txt

NewUpdateMDKlog.txt View - New MDK update log (22.3 KB)

NewBootlog.txt View - Bootlog the same as yours (795 Bytes)

FailedToMount.PNG View - Blue letter advice (37.1 KB)

BootlogError.txt View (5.86 KB)

RE: Problems with the first time configuration - Added by Jonathan Cormier about 4 years ago

Hector Bojorquez wrote:

There shouldn't be a space in the console arg. "console=ttyS1,115200n8"
Also root should have an '=' not a '-'.

sorry about that, I was watching from the other PC and typing in the one with Network connection for making the post, but in the bootlog is OK,

There should be a space between run and flashargs. The run command executes whatever is written into an env variable as if it was typed and run manually. So "run flashargs" will execute the following commands, essentially setting the bootargs variable >to the correct settings. Note: The variable bootcmd is autorun during boot or when you execute the command "boot".

This one was a real error, now corrected.

Actually this is part of the Reprogramming_a_Dead_Board guide. Search for "config set" on that wiki page.

I finished all the steps and made the Flashing again, I got the same bootlog as yours, is attached.

I am able to continue the booting process with the boot command, all the process runs and finish but with a blue letter advice on it about,

Failed to mount /sys/kernel/security: No such file or directory this is attached too.

This is a error is normal and doesn't hurt anything.

I tried to look for the IP address using root command and later ifconfig there appears some info but without an IP address, you can check it on BootlogError.txt

If you don't have a dhcp server then you will need to set your ip address manually. See Setting_a_Static_IP_Address for instructions.

RE: Problems with the first time configuration - Added by Hector Bojorquez about 4 years ago

This is a error is normal and doesn't hurt anything.


So, the reflashing process went well?

If you don't have a dhcp server then you will need to set your ip address manually. See Setting_a_Static_IP_Address for instructions.

I tried with this Setting_a_Static_IP_Address

U-Boot > print bootargs
bootargs=mem=96M console=ttyS1,115200n8 root=/dev/mtdblock0 rw rootwait
U-Boot > set ipaddr 169.254.60.80
U-Boot > set serverip 169.254.68.150
U-Boot > set gatewayip 169.254.1.1
U-Boot > set netmask 255.255.255.0
U-Boot > saveenv
Saving Environment to SPI Flash...
Erasing SPI flash...Writing to SPI flash...done
U-Boot > print bootargs
bootargs=mem=96M console=ttyS1,115200n8 root=/dev/mtdblock0 rw rootwait
U-Boot >boot

but after booting the IP address was not there either.

root
Last login: Sat Jan 1 00:14:13 UTC 2000 on ttyS1
root@mityomapl138:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:50:C2:BF:8D:B3
inet6 addr: fe80::250:c2ff:febf:8db3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:276 (276.0 B) TX bytes:1112 (1.0 KiB)
Interrupt:33

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

root@mityomapl138:~#

NoStaticIP.txt View (3.35 KB)

RE: Problems with the first time configuration - Added by Jonathan Cormier about 4 years ago

Hector Bojorquez wrote:

This is a error is normal and doesn't hurt anything.


So, the reflashing process went well?

If you don't have a dhcp server then you will need to set your ip address manually. See Setting_a_Static_IP_Address for instructions.

I tried with this Setting_a_Static_IP_Address

@U-Boot > print bootargs
bootargs=mem=96M console=ttyS1,115200n8 root=/dev/mtdblock0 rw rootwait
U-Boot > set ipaddr 169.254.60.80
U-Boot > set serverip 169.254.68.150
U-Boot > set gatewayip 169.254.1.1
U-Boot > set netmask 255.255.255.0
U-Boot > saveenv
Saving Environment to SPI Flash...
Erasing SPI flash...Writing to SPI flash...done

These settings only affect u-boot. You need to configure the ip settings after booting into linux.

U-Boot > print bootargs
bootargs=mem=96M console=ttyS1,115200n8 root=/dev/mtdblock0 rw rootwait
U-Boot >boot@

but after booting the IP address was not there either.

root
Last login: Sat Jan 1 00:14:13 UTC 2000 on ttyS1
root@mityomapl138:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:50:C2:BF:8D:B3
inet6 addr: fe80::250:c2ff:febf:8db3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:276 (276.0 B) TX bytes:1112 (1.0 KiB)
Interrupt:33

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

root@mityomapl138:~#

https://support.criticallink.com/redmine/projects/arm9-platforms/wiki/Setting_a_Static_IP_Address#MMCSD-Card-or-NAND-File-System

In order to edit the /etc/network/interfaces file you will need to use the vi text editor. vi while being a powerful editor isn't very self explanatory. See this tutorial for some intro http://www.howtogeek.com/102468/a-beginners-guide-to-editing-text-files-with-vi/.

RE: Problems with the first time configuration - Added by Hector Bojorquez about 4 years ago

Now it's working, thanks a lot Jonathan!

RE: Problems with the first time configuration - Added by Nourhan Elsayed almost 4 years ago

Hello,
I connected my device to the serial port and set the baude rate as attached (teraterm.png).
However, i get no response from the terminal. nothing shows up. why?
thanks.

teraterm.PNG View (6.01 KB)

RE: Problems with the first time configuration - Added by Hector Bojorquez almost 4 years ago

Hi Nourhan,

Did you check that your COM port is the correct one?,
after made the serial port configuration, did you make a reset to the card?
Your serial configuration looks good, I'm using the same configuration with a Null Modem Serial Cable connected directly from the card to my serial port's PC.

Héctor

RE: Problems with the first time configuration - Added by Jonathan Cormier almost 4 years ago

Thanks Hector, he was able to get the serial working by using the null modem cable.

(26-35/35)
Add picture from clipboard (Maximum size: 500 MB)