Project

General

Profile

LCD Framebuffer Problem

Added by Se-Sang Mun over 4 years ago

Hi,

I am being tested with Dev Kit for L138-FI-236-RL and 4.3In WQVGA LCD.
The version of the L138-FI-236-RL is expected to be C.("14-08-06 C" on the sticker on the back of the board is shown.)

I tried to follow the insturctions to test QT Start Guide.
(https://support.criticallink.com/redmine/projects/arm9-platforms/wiki/QT_Starter_Guide)
(https://support.criticallink.com/redmine/projects/arm9-platforms/wiki/LCD_configuration)
(https://support.criticallink.com/redmine/projects/arm9-platforms/wiki/Programming_the_FPGA)

My test procedure is as follows:

1. The QT executable file is built successfully, after installing QT SDK fo Linux/X11 32-bit.
2. The kernel is rebuilt successfulley for configured to enable the framebuffer.
3. At u-boot prompt, Setting the LCD Panel to NEC_NL4827HC19-05B.
4. After rebootting the board, I do not see a /dev/fb0(or a /dev/fb). So, I create the fb0 device node.
5. I run the following commands:
1) insmod fpga_ctrl.ko
2) insmod ads7843.ko
3) echo 1 > /sys/devices/fpga_ctrl/cmd
4) echo 2 > /sys/devices/fpga_ctrl/cmd
5) cat fpga_lcd_lx45.bin > /sys/devices/fpga_ctrl/image
=> The done LED lights.
6) echo 3 > /sys/devices/fpga_ctrl/cmd
7) cat /sys/devices/fpga_ctrl/state
=> 4 : PROGRAMMED
8) fbset -g 480 272 480 272 16
=> fbset: can't open '/dev/fb0': No such device
9) rm /etc/dev.tar
10) ./QTStart_Test -qws
=> QScreenLinuxFb::connect: No such device
=> Error opening framebuffer device /dev/fb0

I'm not sure where these errors come from.
Additionally, after rebootting the board,the fb0 node that created in the step 4 does not seem in the /dev. Why??
I attach the log file from serial console.
Thank you -
se-sang

test_log.TXT View (13 KB)


Replies (6)

RE: LCD Framebuffer Problem - Added by Jonathan Cormier over 4 years ago

What kernel are you using? Which defconfig? The lcd configuration is done in the file arch/arm/mach-davinci/baseboard-industrialio.c function baseboard_setup_lcd(). You may want to place some print statements in there to make sure the correct thing is being configured.

RE: LCD Framebuffer Problem - Added by Se-Sang Mun over 4 years ago

After rebuiling the kernel (kernelversion 3.2.0) with gcc version 4.5.4, I had to re-download the kenel.
I made the bin file of FPGA based on the contents of the sites below.
https://support.criticallink.com/redmine/projects/arm9-platforms/wiki/Building_FPGA_Examples_from_MDK

root@mityomapl138:/app#
root@mityomapl138:/app# uname a
Linux mityomapl138 3.2.0+ #1 PREEMPT Thu Nov 19 03:32:56 EST 2015 armv5tejl unknown
root@mityomapl138:/app#
root@mityomapl138:/app#
root@mityomapl138:/app# ls -al /dev/fb*
lrwxrwxrwx 1 root root 3 Apr 9 04:31 /dev/fb -> fb0
crw-rw---
1 root video 29, 0 Apr 9 04:01 /dev/fb0
root@mityomapl138:/app#
root@mityomapl138:/app#
root@mityomapl138:/app# cat /proc/fb
0 DA8xx FB Drv
root@mityomapl138:/app#
root@mityomapl138:/app#
root@mityomapl138:/app# ls
QTStart_Test fbfill_3-27-2015 fpga_gpio.ko fpga_lcdctlr.ko
ads7843.ko fpga.bin fpga_i2c.ko ver_4.3.3
fbfill fpga_ctrl.ko fpga_lcd_lx45.bin
root@mityomapl138:/app#
root@mityomapl138:/app#
root@mityomapl138:/app# insmod fpga_ctrl.ko
Disabling lock debugging due to kernel taint
fpga fpga_ctrl: loading the fpga_ctrl module.
root@mityomapl138:/app#
root@mityomapl138:/app# insmod ads7843.ko
root@mityomapl138:/app#
root@mityomapl138:/app# insmod fpga_lcdctlr.ko
root@mityomapl138:/app#
root@mityomapl138:/app# echo 1 > /sys/devices/fpga_ctrl/cmd
root@mityomapl138:/app# echo 2 > /sys/devices/fpga_ctrl/cmd
root@mityomapl138:/app# cat fpga_lcd_lx45.bin > /sys/devices/fpga_ctrl/image
root@mityomapl138:/app# echo 3 > /sys/devices/fpga_ctrl/cmd
fpga fpga_ctrl: Found Device ID 00-Base Module (01.01) at C681A000
fpga fpga_ctrl: Found Device ID 23-ADS7843 Touch Screen (01.02) at C681A080
input: ADS7843 Touchscreen as /devices/fpga_ctrl/1/input/input0
fpga fpga_ctrl: enable_irq_vector (0,0,1)
fpga fpga_ctrl: Found Device ID 02-LCD Settings Controller (01.00) at C681A180
fpga_lcdctlr 3: FPGA LCDCTLR Loaded
root@mityomapl138:/app#
root@mityomapl138:/app#
root@mityomapl138:/app# cat /sys/devices/fpga_ctrl/version
PROGRAMMED
FPGA Version : 01.00
FPGA Date : 2010-04-20
Base Module Version : 01.01
Base Module Date : 2010-09-27
root@mityomapl138:/app# cat /sys/devices/fpga_ctrl/state
4 : PROGRAMMED
root@mityomapl138:/app#
root@mityomapl138:/app#
root@mityomapl138:/app# fbset

mode "480x272-98" # D: 21.429 MHz, H: 33.069 kHz, V: 97.838 Hz
geometry 480 272 480 544 16
timings 46666 64 64 32 32 40 2
accel false
rgba 5/11,6/5,5/0,0/0
endmode

root@mityomapl138:/app#
root@mityomapl138:/app#
root@mityomapl138:/app# ./fbfill_3-27-2015 -w 480 -h 272
Framebuffer w = 480 h = 272
opening /dev/fb
root@mityomapl138:/app#
root@mityomapl138:/app#
root@mityomapl138:/app#

Unfortunately, the LCD does not show anything.
Perhaps, can you provide a bin-file for the XC6SLX45 FPGA??

Thank you --

se-sang

RE: LCD Framebuffer Problem - Added by Michael Williamson over 4 years ago

Hello,

You may need to enable the backlight / LCD with the fpga_lcdctlr driver.

There should be a sysfs entry for the backlight with controls for enabling the LCD (powering it on).

I don't have hardware at the moment, when someone else gets in the office I will see if we can reproduce the issue and/or supply an FPGA image. Are you using 80-000289RI-1 (NEC NL4827HC19-05B)?

-Mike

RE: LCD Framebuffer Problem - Added by Se-Sang Mun over 4 years ago

Hi, Mike

I am using with Dev Kit for L138-FI-236-RL and 4.3In WQVGA LCD.
I had to set the LCD Panel to NEC NL4827HC19-05B in the u-boot.

Can you explain in detail for eabling the backlight/LCD??

And, I would like to know the circuit diagram associated with the LCD operation.
Where can I find the schematics for the L138-FI-236-RL module and/or the development base board?

Thank you,

se-sang.

RE: LCD Framebuffer Problem - Added by Se-Sang Mun over 4 years ago

The P/N of the Dev Kit for L138-FI-236-RL is 80-000382 and the P/N of LCD is 80-000536.

RE: LCD Framebuffer Problem - Added by Alexander Block over 4 years ago

Se-Sang,

Please download the following .zip file (https://www.dropbox.com/s/hf8l6wqtxa72a04/lcd_xilinx_13_2-2-1-13.zip?dl=0) which contains source code as well as a pre-built LX45 binary image that supports the LCD display for the L138 development kit. The binary image you would want to use is the "industrialio_lcd_lx45.bin". This was built using Xilinx 13.2.

Additionally I have attached a sample script that can be used to load the FPGA from Linux, the necessary drivers and set the backlight as well. Note that once loaded you should see a blue screen displayed on the LCD display even without using the fb_fill test. This script is based upon all items being located in the /home/root/ directory.

Hopefully this FPGA build resolves the issue but please let us know the outcome.

I have attached a copy of the driver boards schematic in PDF format as well.

Thank you,

Alex

    (1-6/6)
    Add picture from clipboard (Maximum size: 500 MB)