Project

General

Profile

Activity

From 04/04/2016 to 05/03/2016

04/26/2016

01:20 PM Software Development: RE: ifup / ifdown Equivalent for systemd
Ben,
Your concern is valid and I don't have a direct answer now. The @ip@ command is the correct one to use to con...
Bob Duke
11:04 AM Software Development: RE: Linker memory layout.
I think these errors have been over come. I'm using the 8000 tcf file. I am able to run the program and debug a littl... Edwin McKay
10:59 AM Software Development: RE: Linker memory layout.
Edwin, Did you figure this out?
Some comments from Dave here:
> Could it be trying to use two .cmd files?
> At...
Jonathan Cormier
09:14 AM Software Development: DDR configuration for AISgen on MityDSP-L138
We are trying to flash our firmware on the MityDSP-L138 to run code from the DDR. We are using the AISGen tool from T... Friedrich Feichtinger

04/22/2016

10:59 AM Software Development: RE: WFI and Bluetoth support
I am looking at the Redpine Signals RS9113-NZB.
We may be using it in anther product Using the TI arm file system th...
steven poffenbarger
10:33 AM Software Development: RE: WFI and Bluetoth support
Steven,
We've integrated multiple Wifi/BT chipsets with our products. In most cases we have to integrate an extern...
Bob Duke
08:56 AM Software Development: WFI and Bluetoth support
Does the Yocto file system support the TI or other vendors wifi and bluetooth on the DBric3?
what is the interface t...
steven poffenbarger

04/21/2016

10:49 AM Software Development: Emulator stops working very often.
I continually get these sort of messages while I try to step through the DSP code. Some times I can debug for a few m... Edwin McKay

04/20/2016

04:58 PM Software Development: RE: No Prompt from Uboot
Thanks. You got it.
Only way to be sure was to cut the i2c traces on the carrier. Biked over to my partners and go...
Ian St. John
09:02 AM Software Development: RE: No Prompt from Uboot (update)
Ian St. John wrote:
> ALSO note that I am worried about the message "error reading I2C Configuration Block". Is th...
Jonathan Cormier
12:37 AM Software Development: RE: No Prompt from Uboot
I don't have either a second (working) module or a standard carrier board. We couldn't afford them when we started an... Ian St. John

04/19/2016

05:39 PM Software Development: RE: Any special thing to get new ObjectXXX to work.
Hi Edwin,
Your project should have a .tcf file. This should define how memory is configured and how large your he...
Gregory Gluszek
04:35 PM Software Development: RE: No Prompt from Uboot
Ian,
Can you let us know if the behavior changes when this module is used in the Industrial IO Development Board (...
Alexander Block
03:34 PM Software Development: RE: No Prompt from Uboot (baahhh)
Well, it worked for two or three runs. Now it hangs on the uart initialization? Thinks that the uart is busy with out... Ian St. John
12:46 PM Software Development: RE: No Prompt from Uboot (update)
Imported and ran UBL to CCS 6.1.2. Changed only DEVICE_UART_PERIPHNUM to 1 from 2 in devices_uart.h to get UBL messag... Ian St. John

04/17/2016

12:51 PM Software Development: RE: No Prompt from Uboot
Mike,
Thanks for the description. I think your confusion is more about not understanding why it doesn't work (like...
Ian St. John
08:17 AM Software Development: RE: No Prompt from Uboot
Hello,
So I'm struggling a bit to get the full picture of what is going on.
Are you saying that you are running...
Michael Williamson

04/16/2016

06:21 PM Software Development: RE: No Prompt from Uboot
Uboot won't load (SPI mem = 0, i.e. says file too big on load of UBL)
Backup code was NOT the solution. Recent code ...
Ian St. John
02:09 PM Software Development: RE: No Prompt from Uboot (update)
I found and old backup where SpiWriter still works. Got my application code loaded into SPI NOR flash. I will try to ... Ian St. John

04/15/2016

05:26 PM Software Development: Any special thing to get new ObjectXXX to work.
I am new'ing an object and stepping through the assembly I end up in SYS_error with an error of 1 and a message of "M... Edwin McKay
03:08 PM Software Development: RE: ifup / ifdown Equivalent for systemd
Well, I found something that works, but it doesn't seem very "clean" or symmetrical. I found the following to bring ... Ben Atkinson
10:48 AM Software Development: ifup / ifdown Equivalent for systemd
Hello,
In the new ALPHA Release 2016.01 filesytem, what is the "systemd way" of performing ifdown eth0 and ifup et...
Ben Atkinson
11:29 AM Software Development: No Prompt from Uboot
Background:
I have a custom carrier board utilizing a 1808-FX-225-RC SOM (AM1808 only). Compiling using CCS 6.1.2. I...
Ian St. John
10:04 AM Software Development: RE: Problem using XDS200 USB emulator.
As I mentioned, you may be able to use the debugger to load the application. I believe you should load
some DSP cod...
Dave Stehlik

04/13/2016

08:41 AM Software Development: RE: Problem using XDS200 USB emulator.
Dave,
Thanks for the reply.
1. Easier said than done ;)... The project is very "integrated". I have pared it down t...
Edwin McKay

04/12/2016

05:44 PM Software Development: RE: Problem using XDS200 USB emulator.
Hello Edwin,
Those steps do appear correct.
All project I have done on the L138 have used dsplink to communicat...
Dave Stehlik
04:11 PM Software Development: RE: Problem using XDS200 USB emulator.
Yes, I could step through the HelloWorld app. Is there anything else that might run before the main()?
I have chang...
Edwin McKay
02:20 PM Software Development: RE: Problem using XDS200 USB emulator.
Hello Edwin,
I agree that since the debugger is looking for utl_halt.c something has gone wrong before main.
Obvi...
Dave Stehlik
01:50 PM Software Development: RE: Problem using XDS200 USB emulator.
I have tried to debug our main application. I copied the "waiting" loop from the Hello World app to the main. Wheneve... Edwin McKay
10:16 AM Software Development: RE: Problem using XDS200 USB emulator.
Well sort of debug. It hit the break point, I changed the waitForMe variable and stepped one line. But after stepping... Edwin McKay
09:46 AM Software Development: RE: Problem using XDS200 USB emulator.
Edwin McKay wrote:
> To get at least pass the "Test Connection" I installed the drivers. I must have missed that ste...
Jonathan Cormier
09:44 AM Software Development: RE: Problem using XDS200 USB emulator.
To get at least pass the "Test Connection" I installed the drivers. I must have missed that step when I installed CCS... Edwin McKay

04/11/2016

03:29 PM Software Development: RE: Problem using XDS200 USB emulator.
Edwin McKay wrote:
> I have gotten a little further. The "Test Connection" now seems to work. So I guess Ubuntu can ...
Jonathan Cormier
03:16 PM Software Development: RE: Problem using XDS200 USB emulator.

I have gotten a little further. The "Test Connection" now seems to work. So I guess Ubuntu can talk to the XDS modu...
Edwin McKay
11:00 AM Software Development: RE: Problem using XDS200 USB emulator.
Edwin wrote:
> I will try searching the TI web site.
Good idea. Let us know if you find something that helps.
Jonathan Cormier
10:59 AM Software Development: RE: Problem using XDS200 USB emulator.
Thanks for the update. I will see if we can get one in house. In the mean time try searching TI's e2e to see if any... Jonathan Cormier
10:34 AM Software Development: RE: Problem using XDS200 USB emulator.
From TI's web site the XDS510 & XDS560 are both obsolete?
I will try searching the TI web site.
Edwin McKay

04/08/2016

02:13 PM Software Development: RE: gcc 4.8.4 l38F link can't resolve POOL_translateAddr
Steve,
Thank you for posting the fix.
We haven't tested using the Yocto filesystem with earlier MDK. It is expe...
Bob Duke

04/07/2016

03:46 PM Software Development: RE: Problem using XDS200 USB emulator.
Edwin,
Unfortunately we have not used the XDS200 on any platform so we don't even have one to try and reproduce th...
Alexander Block
03:15 PM Software Development: Problem using XDS200 USB emulator.
I am trying to debug my DSP project (actually just the HelloWorld program). I have a XDS200 debugger plugged into my ... Edwin McKay
09:04 AM Software Development: RE: gcc 4.8.4 l38F link can't resolve POOL_translateAddr
Hi Bob
I think I found the problem.
DSPLINK.lib is in a different location than in the original setup.
Is MDK_20...
steven poffenbarger

04/06/2016

03:06 PM Software Development: RE: gcc 4.8.4 l38F link can't resolve POOL_translateAddr
Steven, can you share the Makefile you are using? Bob Duke
12:08 PM Software Development: gcc 4.8.4 l38F link can't resolve POOL_translateAddr
I using gcc 4.8.4 compiling a arm program for Dbric 3 yocto file system.
I get a link error "/home/mitydsp/workspace...
steven poffenbarger

04/04/2016

04:31 PM Software Development: RE: How to Enable a systemd Unit Template for Boot Execution
Ben,
Thank you for the follow-up on this bug. I'm glad you got it working. I can't find any reference to case-sens...
Bob Duke
03:59 PM Software Development: RE: How to Enable a systemd Unit Template for Boot Execution
Bob,
So I was able to home in on the issue. It centers on the parameter being passed to the unit file. As stated...
Ben Atkinson
08:51 AM Software Development: RE: How to Enable a systemd Unit Template for Boot Execution
Yocto poky daisy (1.6.3) Jonathan Cormier
08:34 AM Software Development: RE: How to Enable a systemd Unit Template for Boot Execution
Bob,
We are looking at workarounds getting the enable to function. Do you have a Yocto version number associated ...
Ben Atkinson
 

Also available in: Atom

Add picture from clipboard (Maximum size: 600 MB)